Movable Type 〜Google, mixi認証に必要なperlモジュール〜

Google, mixi認証に必要なperlモジュール


Movable Type 4.25 以降では、Google と mixi の認証が使えるようになった。
(Google や mixi のアカウントでコメントできたりする。)

しかし、サーバ側に必要な Perl モジュールが入っていないと
Google (この認証方式に必要なPerlモジュールがいくつか不足しているようです)
というエラーが出て、これらの認証を有効にすることができない。

どうやら、Crypt::SSLeay という、ネットワークトラフィックのSSL暗号化を可能にする Perl モジュールが足りないかららしい。
そこで、apt ラインでこの Perl モジュールをインストールする。

$ sudo apt-get install libcrypt-ssleay-perl

これでめでたく Google と mixi の認証が使えるようになる。

AppleCare Protection Plan Mac Book Air iMac

RSS MarkRSS Mark 2
   
 


        ※このHPにより生じたトラブルについて、一切責任を負いません。